la mise à jour du logiciel itunes ignore ne fonctionne pas

J'ai OSX 10.5.6 et iTunes 10.4.1 sur mon ordinateur portable. J'ai éteint la mise à jour du logiciel pour iTunes, mais chaque fois que je clique sur une chanson, j'obtiens une notification qui dit

iTunes nécessite l'installation de Safari 4.0.3 ou version ultérieure pour utiliser l'iTunes Store avec iTunes. Utilisez Software Update pour download et installer la dernière version de Safari.

Je n'essaie pas d'utiliser le magasin iTunes, alors je ne sais pas pourquoi cela surgit. Je préférerais ne pas mettre à jour Safari car je n'utilise jamais ce browser. Suggestions?

Comme iTunes utilise le kit Web et le HTML pour fonctionner dans le magasin, vous pourriez en avoir besoin pour que le logiciel fonctionne.

Si l'application fonctionne toujours selon vos besoins, vous pouvez sans risque ignorer le message, mais si vous n'utilisez pas ce browser, pourquoi ne pas simplement le mettre à jour et laisser iTunes être heureux?